スポンサーリンク

【LangChain】バージョン依存関係でPython仮想環境にインストールできない

記事内に広告が含まれています。

日々アップデートが高速で実施されていくLangChainです。

Windows環境で開発を行い、requirements.txtを用いてLinuxの仮想環境にライブラリをインストールしようとしたら、LangChainに関係するライブラリのバージョン依存関係により、インストールができませんでした。

結論としては、LangChain関連のライブラリを全て最新バージョンにしたら、インストールできました。

開発しているときは問題なかったのですけどね・・

事象ですが、requirements.txtに記載されていた内容は以下のとおりです。

langchain==0.1.7
langchain-community==0.0.20
langchain-core==0.1.26
langchain-openai==0.0.7
langsmith==0.1.8

エラーメッセージは以下のとおりでした。

・・・全部満たすの無理じゃん。

となったので、上記のライブラリ全て入れなおして(langchain入れればlangchain-openai以外は勝手に入ったかな?)再度インストールを試みたところ成功しました。

LangChainは、アップデートするとワーニングが出るようになったりしていますが、徐々に落ち着いてくれると嬉しいですね。

スポンサーリンク
スポンサーリンク
スポンサーリンク
Generative AILangChainPython
著者SNS
タイトルとURLをコピーしました